Outlook 365 Add-in: signatures loading with delays

Incident Report for Xink

Postmortem

Description

The Outlook 365 Add-in encountered an issue where email signatures failed to load promptly for a subset of users. The delay was noticeable when users opened the email composition window, causing a degraded user experience. The issue was reported by multiple users across different regions and was traced back to internal changes in how image URLs are processed within the add-in.

Root Cause

The issue was caused by recent internal changes to the image URL processing logic in the Outlook 365 Add-in. Specifically, a new validation step for image URLs introduced unintended latency when fetching signature images from external servers.

Impact

  • User Experience: Delays in signature loading when composing emails.
  • Business Impact: No critical data loss or security issues.

Resolution

  1. Immediate Action: Deployed a temporary workaround to bypass the new URL validation step, reducing latency for affected users.
  2. Permanent Fix: Rewrote the image URL processing logic to optimize performance and remove excessive validation checks.
  3. Deployment: Rolled out the fix to production after thorough testing in a staging environment.
  4. Monitoring: Post-deployment monitoring confirmed that signature loading times returned to normal.
Posted May 13, 2025 - 14:31 CEST

Resolved

This incident has been resolved.
Posted May 07, 2025 - 12:01 CEST

Investigating

We are investigating an issue where the Outlook 365 Add-in is experiencing delays in loading email signatures for some users.
Posted May 07, 2025 - 11:10 CEST
This incident affected: Outlook 365 Add-in.