EU Server Side Service Disruption

Incident Report for Xink

Resolved

This incident has been resolved.
Posted Mar 03, 2026 - 13:37 CET

Investigating

Affected clients are seeing permanent delivery failures when sending emails, with the error: "messages undeliverable to one or more recipients."

Our team is actively investigating and implementing fixes. We will share more details soon.
Posted Mar 03, 2026 - 12:27 CET
This incident affected: EU Data Centre (Microsoft Azure Cloud) (Server-side (Re-routing)).