Microsoft 365 add-in service is currently experiencing an issue.
Incident Report for Xink
Postmortem

Summary:
Users may have been unable to use already acquired add-ins within the Outlook desktop app, Outlook on the web and Outlook mobile app.

Microsoft Issue ID: EX829938

Incident Details:
A recent code change by Microsoft contains a bug, resulting in calls to the service to parse the wrong value and this impact.

Mitigation Steps:
Issue was reported to Microsoft whom applied a code fix to address the underlying problem.

Posted Jul 23, 2024 - 07:33 CEST

Resolved
This incident has been resolved.
Posted Jul 23, 2024 - 00:44 CEST
Update
Microsoft confirmed that the service has been restored. This incident is now resolved.
Posted Jul 23, 2024 - 00:40 CEST
Monitoring
Microsoft 365 add-in service is currently experiencing an issue. Some add-ins may not work consistently, and in some instances, they may completely disappear from outlook. This problem is not isolated to Xink; even native Microsoft add-ins are experiencing similar issues. Microsoft didn't report the problem, but here is unofficial mention of the issue:
https://techcommunity.microsoft.com/t5/outlook/outlook-web-apps-not-showing-up/m-p/4197943

We already working with Microsoft to resolve this issue.
Posted Jul 22, 2024 - 20:59 CEST
This incident affected: Outlook add-in.