Xink add-in in Outlook on the web - Signature image are loading with high latency

Incident Report for Xink

Resolved

This incident has been resolved.
Posted Nov 08, 2025 - 01:29 CET

Update

Microsoft has published official details regarding this incident on the Microsoft 365 Service Health Dashboard (SHD) under ID EX1183800.

Our investigation confirms that the issue originates from Microsoft’s services and is not related to the Xink platform.

We’ll continue to monitor the situation, but no action is required from Xink customers at this time. For more information, please refer to Microsoft’s SHD. https://admin.cloud.microsoft/?source=applauncher#/servicehealth/:/alerts/EX1183800
Posted Nov 08, 2025 - 01:28 CET

Monitoring

We are actively investigating reports of slow image loading when composing a new email. This is only specific to the Xink add-in in Outlook on the web. Initial analysis confirms the issue does not occur in Outlook Classic or the New Outlook preview.

Affected users may experience delayed rendering of signature images, intermittent image load errors, or instances where images fail to load entirely.

Evidence points to a performance degradation in the Microsoft API used by the add-in to retrieve signature assets in Outlook on the web.
Posted Nov 07, 2025 - 10:56 CET
This incident affected: Outlook 365 Add-in.