EU - outlook add-in connection error, slow signature load

Incident Report for Xink

Resolved

Preliminary Root cause: Unusually high spike in requests.

Mitigation: We increased capacity to handle peak client load in the EU DC. Services are operating normally.
Posted May 26, 2026 - 11:21 CEST

Identified

The issue has been identified and a fix is being implemented.
Posted May 26, 2026 - 11:02 CEST
This incident affected: EU Data Centre (Microsoft Azure Cloud) (Outlook Add-in).