Azure AD integration error: The provided client secret keys are expired.

Incident Report for Xink

Resolved

This incident has been resolved.
Posted Apr 03, 2026 - 11:44 CEST

Monitoring

The error occurred because the client secret used by our service principal for the Azure AD (Microsoft Entra ID) integration had expired.

A client secret acts as a password that allows our application to authenticate and communicate with Microsoft Entra ID. These secrets are intentionally configured to expire after a set period for security reasons. When the secret reached its expiration date, authentication attempts began failing with the error:

"The provided client secret keys for app are expired."

We have generated a new client secret and updated all affected systems. We scheduled the next renewal to prevent this from happening again.
Posted Apr 03, 2026 - 04:45 CEST
This incident affected: US Data Center (Microsoft Azure Cloud) (Integrations), EU Data Centre (Microsoft Azure Cloud) (Integrations), CA Data Center (Microsoft Azure Cloud) (Integrations), UK Data Centre (Microsoft Azure Cloud) (Integrations), and AU Data Centre (Microsoft Azure Cloud) (Integrations).