The Outlook 365 Add-in for Classic Outlook encountered connection issue (Error 503) where email signatures failed to load.
Root Cause
The issue was caused by an important update for the Add-in which requires Classic Outlook to restart in order to complete.
Impact
User Experience: Add-in is not connecting and signatures are not inserted when composing emails.
Business Impact: No critical data loss or security issues.
Resolution
Users must restart Outlook app to clear the error and complete the Add-in update.
Posted Dec 05, 2025 - 04:07 CET
Resolved
Incident has been resolved
Posted Dec 05, 2025 - 03:57 CET
Monitoring
Applied updates for the add-in caused initial connection issue with Classic Outlook. Restarting the Outlook application will fix and restore the connection.
Please advise users to restart their Outlook application to clear the error.
Posted Dec 04, 2025 - 23:18 CET
Investigating
Clients may encounter connection issue with the add-in, showing error 503. We are currently investigating this issue.