EU - outlook add-in signature load is slow

Incident Report for Xink

Resolved

This incident has been resolved.

Root cause: EU database capacity lagged behind growing client traffic.

Mitigation: we scaled and updated to higher tier the EU managed database to handle the increased load. This will prevent latency issue in the future.
Posted May 19, 2026 - 11:49 CEST

Update

We are continuing to work on a fix for this issue.
Posted May 19, 2026 - 11:42 CEST

Identified

The issue has been identified and a fix is being implemented.
Posted May 19, 2026 - 09:45 CEST
This incident affected: Outlook Add-in.