EU - outlook add-in error, no signature load

Incident Report for Xink

Resolved

Root cause: A background maintenance job began at 9:15 and pushed the database into heavy load. The spike was driven by an unusually high volume of clicks from misconfigured settings.

Mitigation: We increased capacity to handle peak client load in the EU DC. Services are operating normally.
Posted May 20, 2026 - 12:00 CEST

Identified

The issue has been identified and a fix is being implemented.
Posted May 20, 2026 - 09:45 CEST
This incident affected: Outlook Add-in.